WordPress出现PHP错误或HTTP 500错误

作者 : 清风 本文共426个字,预计阅读时间需要2分钟 发布时间: 2020-02-1 共181人阅读

当前最新的WordPress 5.3版本已经开始要求用户使用PHP7.0以上的环境了,这对于开发者来说确实是件好事情。

早前,一小部分客户在安装我们的WordPress主题的时候可能会出现PHP错误(常见于Linux主机):

或者直接就是HTTP 500错误(常见于Windows主机),导致网站无法打开:

这两个错误都是由于网站主机服务器环境的PHP版本太低导致的。由于我们的WordPress主题都是基于PHP 5.5以上的语法来开发的,所以低于PHP 5.5的主机环境会报错。登陆您的主机管理后台,或者联系主机商家,升级切换到PHP 5.5以上的版本(建议直接PHP 7.0+),这个问题就解决了,网站就不错出现PHP错误代码,也不会出现HTTP 500报错了。

国内很多老旧主机还在使用的PHP 5.4环境已经不适合WordPress了,既不安全,运行也慢。新版PHP在安全性和运行效率上有较大提升,建议所有用户直接升级主机环境到PHP 7.0以上,与时俱进,使用无忧。

版权免责声明

本资源仅用于个人学习测试使用,禁止用于任何商业环境,请于下载后24小时内删除,如果你觉得满意,请购买正版!

  1. 1、本站名称:百淘吧资源网
  2. 2、本站永久网址:https://www.baitaoba.com
  3. 3、本站资源大多存储在百度云盘,如发现链接失效,请联系客服进行补录链接 我们会第一时间更新。
  4. 4、本站提供的源码、模板、软件工具等其他资源,都不包含技术服务,如需要技术单独联系客服,有偿服务! 请大家谅解!
  5. 5、本站仅提供学习的平台,所有资料均来自于互联网收集或个人购买,版权归原创者所有!本站不提供任何保证,并不承担任何法律责任,如果对您的版权或者利益造成损害,请提供相应的资质证明,我们将于3个工作日内予以处理。

百淘吧资源网 » WordPress出现PHP错误或HTTP 500错误

常见问题FAQ

网站源码提供售后服务吗?
部分源码提供售后服务的!
本站源码支持更新吗?
永久免费更新!

发表评论